Tic »

Troubleshooting and FAQ

Tasks

edit SideBar

Problem: Data is not transmitting over the transceivers (2 player mode).

Solution: There could be 2 issues, provided all wires have been connected properly. The radio transceivers are not working or there is something wrong with the code. Run the helloWorld _tx and helloWorld_rx sketches and upload them onto the arduino boards respectively. Make sure the radios are already wired to the boards. Now open the serial monitor to check if packets are being sent from the board with helloWorld_tx to helloWorld_rx. If this works, it means the transceivers are fine. Next you want to follow the instructions in session 5 of the instructional video set and check if the X is being transmitted. If it is, the hardware is fine, it must be the code. Go over the code again; use the serial monitor for debugging each section of the code till a problem is identified. Try not to tamper with the slaveReceive() and slaveSend() methods. A good idea would be keeping all statements that cause graphic changes in a block. This makes debugging easier.

Problem: In single player mode, computer plays more than one turn.

Solution: This is probably because the screen detects a tap as more than one touch, so it gets two or more points in the same location. This prompts the computer to play two or more turns too. Using a one second delay between the turns between computer and player is an easy solution to this problem. A two second delay should suffice. Make sure to remove this delay while playing two players as you donít want any delay in the sending and receiving of information.


Page last modified on August 31, 2012, visited times

Edit - History - Print - Recent Changes (All) - Search