for working in smitty with xterm use ctrl-lmb and select 'old function-keys' if you are doing a fresh install, just use the partition defaults and resize later (see below) resizing partitions: do this right away, *** you can't shrink partitions, only grow them *** use chfs, or smit http://publib.boulder.ibm.com/infocenter/pseries/index.jsp?topic=/com.ibm.aix.doc/cmds/aixcmds1/chfs.htm also you can use M for megs or nothing for 512-byte blocks example: chfs -a size=10G / older aix i dont think support the suffixes for smit do: System Storage Management -> file systems -> add/change/show/del heres what build14 and 31 look like (12-01-2005) in list all filesystems Name Nodename Mount Pt VFS Size Options Auto Accounting /dev/hd4 -- / jfs 10092544 -- yes no /dev/hd1 -- /home jfs 16777216 -- yes no /dev/hd2 -- /usr jfs 10092544 -- yes no /dev/hd9var -- /var jfs 8388608 -- yes no /dev/hd3 -- /tmp jfs 2097152 -- yes no /proc -- /proc procfs -- -- yes no /dev/hd10opt -- /opt jfs 262144 -- yes no /dev/lv00 -- /home/condor/execute jfs 41943040 rw yes no /dev/lv01 -- /usr/sys/inst.images jfs 4194304 rw yes no nmi-aix is a little different (/ is twice as big, the rest adjusted for compensation) (accident) so... chfs -a size=10092544 / chfs -a size=16777216 /home chfs -a size=10092544 /usr chfs -a size=8388608 /var chfs -a size=2097152 /tmp and then make /home/condor/execute (and the inst.images?) a useful switch on gunzip is -c (to unzip to stdout, do what gzcat does) gunzip -c blah.tar.gz | tar xvf - aix toolbox for linux: a bunch of supported free software rpms try http://www-03.ibm.com/servers/aix/products/aixos/linux/download.html or google installing openssh aix get wget right away, and bash if you like it also use wget --passive-ftp or your ftp downloads will fail for bash try alias wget="wget --passive-ftp" ssh is NOT in there as of 12-1-2005 try http://sourceforge.net/projects/openssh-aix see http://www-1.ibm.com/support/docview.wss?uid=isg1pTechnote0707 (very good) note: groups/cryptographic for openssl, and you need an ibm id also there are separate release binaries for some things, make sure you get the right ones you need openssl 0.9.7 or greater also get the openssl-devel packages right away zcat blah.Z | tar xvf - inutoc . smitty install on compiling things: make sure you get gnu make as well as gcc etc for compiling things that need them use 'gmake' (gnu make) instead of 'make' (system make) where required on ldap: for 5.2 and up: you need to install ldap.client from the cdroms mksecldap -c -h 192.168.0.1 -d dc=wisc,dc=edu -a "cn=Manager,dc=wisc,dc=edu" -p edit /etc/security/user: replace SYSTEM="compat" with SYSTEM="ldap or compat" for 5.1 and down: (from http://publib.boulder.ibm.com/infocenter/pseries/index.jsp?topic=/com.ibm.aix.doc/cmds/aixcmds3/mksecldap.htm) Attention: Systems running AIX 4.3 and AIX 5.1 which are configured as LDAP clients will only work with servers of AIX schema type. They will not talk to ldap servers of RFC2307 or RFC2307AIX types. so use nss_ldap on aix 5.1 google nss_ldap aix for the client you can use openldap, configure without slapd/slurpd / try w/o bdb (from http://www.padl.com/Articles/nss_ldaponAIX.html) ./configure --with-ldap-dir=/usr/local \ --with-ldap-lib=auto \ --with-ldap-conf-file=/etc/nss_ldap.conf gmake gmake install edit /usr/lib/security/methods.cfg: LDAP: program = /usr/lib/security/NSS_LDAP then put basedn/server in /etc/nss_ldap.conf finally, # chuser SYSTEM="compat or LDAP" default (this modifies /etc/security/user) -- cfengine: some prereqs: openssl, flex, bison... you can just link /usr/bin/yacc to /opt/freeware/bin/yacc also make sure you install libm (math library) off of the aix cd (not installed by default!!!) you can also just put /opt/freeware/bin in your path note the /opt/freeware/bin/yacc is just a shellscript that runs bison -y if you get weird bison/yacc errors at compile time you will need to compile bison when compiling make sure /opt/freeware/bin precedes /usr/bin so you get the right 'm4' command you'll probably end up doing something like: export PATH=/usr/local/bin:/opt/freeware/bin:$PATH cd /path/to/bison ./configure gmake gmake install cd /path/to/cfengine ./configure --with-openssl=/opt/freeware gmake gmake install installing packages, compilers: if you need a newer base.rte base runtime or other requisite packages, you might try updating with an aix maintenance package from http://techsupport.services.ibm.com if there is trouble applying the patch (accept license not available in update_all menus) try without allowing it to install requisite packages, and possibly manually install the requisite packages before proceeding. only new packages need license agreements accepted. it appears this bug was fixed sometime between 5.1-4 and 5.1-9